Lustre 2.10.6 released

By KenRawlings

We are pleased to announce that the Lustre 2.10.6 Release has been declared GA and is available for download. You can also grab the source from git.

There are a number of useful bug fixes in this maintenance release but of particular note is the fix for an issue which could cause data corruption with unaligned page writes for Lustre on ZFS deployments (LU-11663). We recommend anyone who is running Lustre on ZFS on Lustre 2.10.5 to upgrade to 2.10.6 immediately. All other versions of Lustre and Lustre on ldiskfs deployments are not exposed to this issue.

In addition, there are the following notable enhancements over 2.10.5:

  • RHEL 7.6 is now supported for servers and clients (LU-11525)
  • Mellanox OFED 4.5-1 is now the default version built and tested

Details of changes since 2.10.5 can be found in the 2.10.6 change log.

Please log any issues found in the issue tracking system.

Thanks to all those who have contributed to the creation of this release.

We may release Lustre 2.10.7 in the coming months but we will definitely be releasing a 2.12.1 as we start the transition over to 2.12.x as being the active LTS release branch.

|